An important update to the CueServerLib library for CueTouch was released on June 27, 2018.

This update contains a complete rewrite of the connectivity module that connects CueTouch to CueServer. This was done to address continued performance and connection issues between these two devices. Version 6.0.0 is considerably faster than previous versions and avoids several issues related to dropped connections that some customers were experiencing.

Starting with Version 6.0.0, the CueServer object in Qlarity does not need to be set to a specific CueServer hardware type. The CueServerLib now automatically detects and optimizes itself to work with all CueServer models.

This update can be downloaded from the Downloads Tab of the CueTouch product page..

Upgrade Instructions

For existing Qlarity projects that use CueServerLib, follow these simple instructions to make sure your Qlarity project is updated to the latest version.

  • Replace the CueServerLib file in your Qlarity Foundry folder with the version from the 6.0.0 package.
  • That's it.